Can I please get some opinions as to whether this contour file should be manageable on my PC?


#1

I’ve got a (2nd) drone-survey data download that consists exclusively of contour lines, I believe, of steep hillside terrain. For a sense of scale, it’s around 2 acres’ worth, with contours spaced at 6" intervals. I got only as far as importing it to Sketchup from its original .dwg format. But it’s been unusable to me, essentially, because incremental changes to try to change the view or edit the contours result in near-meltdown of my PC, for 20 minutes or half an hour, until the model can refresh.

It’s 64MB in .dwg form, and 337MB in .skp - I managed only to save it, then closed it as quickly as possible…

It wouldn’t surprise me if this were because of some PC problem, and not the file itself. Can anyone please give this a try and see if it behaves badly for you, too?

Link…not sure if this is gonna work: https://drive.google.com/drive/folders/1YRcFUiB0lQwbHPu3E4_5q9v4PbGpV94r?usp=sharing

Tx - Dave


#2

You should really post some details about your PC and the version of SketchUp you are using in order to figure it out.

One of my computers is a:

Mac Book Pro 2015, 3.1GHz i7, 16GB RAM, Intel Iris 6100 1.5GB GPU.

It can run files up to around 3-400 MB before getting annoying but can edit meshes to around 300<B with a lot of patience. After then I have to move to my PC that is a bit more powerful, I can take SketchUp files closer to 800MB in that case.

Custom PC, 4.4GHz i7, 16GB RAM, GTX 980ti 6GB GPU.

A handy step when working with terrain (or cloth in my case) is to open the file in blender first and use something called the decimate modifier. While there are many great reduction plugins in SketchUP, the fact it does not like large mesh’s in the first place can cause an issue to even open the file. Where as Blender can easily open and edit large meshes.

The decimate modifier is a simple three click process to reduce the mesh. You can then export it back into SketchUp at a much smaller size allowing you to edit it no problem.

Here is a tutorial of the modifier on the subject of terrain: https://youtu.be/gq-6X3pzUOE


#3

Thanks Liam.

My PC specs: i7-4770 CPU, 3.4GHz, 12GB memory, 64-bit, GeForce GE710.

Sketchup: 2018.

I’m new at dealing with terrain/contours so I wanted to clarify this: you talk about polys & reducing the amount of detail in that tutorial, but I’ve seen enough iterations of my contour download to know that it’s not a mesh, per se, but rather a series of unconnected contour lines…just squiggly unconnected lines. In coarser versions that the data-processing firm put up for me to download, I could swivel around them without noticeable delay, but those were 10’ intervals, vs now 6". Still, they’re just lines…so intuitively I’d think there wouldn’t be much need for a lot of computing muscle to display & edit them, but that seems not to be the case, at least for me.

Really, what I’d envisioned when signing up to get the drone data, was being able to download and edit a photorealistic model (orthophoto), together with contours, but with the problems even displaying these contours, it seems like this was an impossible prospect.

Were you able to access the g-drive link I posted?

Dave


#4

Ahh I see,

Are you able to export the file at SketchUp 2017 version, at the moment it’s a DWG and I can’t open it on this current laptop as there is no Pro installed.

My PC is rendering over the weekend for a project and I dare not touch it, on my girlfriends Mac at the moment. Otherwise can look tomorrow night.


#5

Liam,

See if you can access this .skp (2018) link: https://drive.google.com/file/d/1bWuCXh_pXBSr5uRuh-RQrzAs1YgWOsr5/view?usp=sharing
(…it’s 329MB. I hope it doesn’t lead you into 20 minutes of CPU overload, like it would me…)

Thanks,

Dave


#6

I looked at your dwg file earlier, but couldn’t import it into SketchUp at all. It seemed to work with a lot of errors then all the lines were squished up in one line in the z-axis.

I can open your SketchUp file though and it looks really impressive. There’s a lot of detail there which is also your problem I suppose. I’m just not sure what to do with it that could simplify it.

It’s a bit sluggish but workable here. I have to use zoom window rather than the scroll wheel as it doesn’t update in real time. After a short delay, it orbits smoothly.

It took 1 minute 20 seconds to open fully ready for editing. I’m on a Mac Pro with 2 quad core E5520s at 2.26GHz and GTX 970 4GB.


#7

I’ve copied a small chunk of the contours as shown in the image and uploaded a skp file. This is ‘only’ 1/4 million edges instead of the almost 6 million in the full file. Try this and see if you can open it.

Each contour is a polyline that isn’t welded, so they’re all separate edges and no faces. To simplify it you could discard every second line or smooth the lines out so they weren’t so accurate, like maybe discard every second vertex draw half the number of segments but still keeping a line on every 6 inch contour.

This could be a ‘fun’ job to write a script to process it.


#8

Nice, I will have a look too tomorrow when I can get back on my own computer.


#9

No need to write a script, you can do it Blender.

Here’s a reduced quality version of that same chunk. I used Blender’s ‘Limited Dissolve’ tool with an angle of 25° to reduce the number of vertices all in one click (and wait). You could tweak this to decide how much detail to retain. It’s a bit like SketchUp’s soften edges tool but it actually removes vertices rather than smoothing them.

This takes the chunk down from 248,552 edges to 115,012 edges.

I haven’t been able to process the whole file as it was taking a long time to import to Blender, out of proportion with the file sizes.


#10

Wow…now I feel like I bit off a lot more than I can chew. But thanks McG and Liam.

McG, That “all on one line” thing you reported was what I was getting with an earlier generation of the download from the host (propelleraero.com), but I’m mystified that you got that from the 6" iteration I linked. I complained about that problem to them re: a previous iteration a few weeks back. Turned out one of their techs had the same bad outcome when he tested it, so he did some mysterious reprocessing, the eventual result of which was a really coarse version (I guess as a prelim test) at 10’ intervals. That one opened fine, but was too lacking in detail. So I asked for something finer and whether 6" was reasonable…and that’s the rest of that story.

I was able to readily open/orbit the ‘chunk’ you carved out. The .skp version performed OK. That made me wonder if my system might handle it now that I’ve rebooted (or something…) er, no. Took me several minutes to get the arrow-cursor over the ‘zoom’ control, then it just choked on my attempt to zoom to eliminate most of the rest of the contours, as I presume you were able to do, McG (yes?) Took me a good thirty minutes to get my disk-usage down from 100%, and even to do that, I had to “end process” to overcome the (not responding) mode.

Stabbing in the dark here, but would that indicate that maybe an SSD would help?

Even once I overcome the current problems, I’m going to have to do a ton of manual tweaking of the contours somehow. You can kind of see where the drone couldn’t quite see below some of the tree-canopies, and in those locations, it models things as if the trees have giant tarps thrown over them…so it’s up to me to try to restore the actual ground-level contours there in some fashion. I kinda hate that, but it’s still an incredible volume of Z-information compared with what I’d get for a huge cost from a regular surveyor.

Apparently LIDAR would be the answer to this because it can simply “see through the trees” from aloft, but it’s a rarity here in Honolulu, or simply doesn’t exist here. Drone guy would like to partner with a surveying firm to buy one for mutual use; I think he said they’re around $120K, though, so they’d have to see a good future for such a large investment to make sense.

Anyway, if you’ve got suggestions for cutting through some of the guesswork etc of this, I’m all ears.

Mahalo - Dave


#11

The SSD will be helpful but it’s not going to make the difference you need.

12GB memory, 64-bit, GeForce GE710 is quite lacking, I think you will struggle without upgrading both of those.

Let me check on my PC when I get home from work today, I was rendering over the weekend so it was unusable but it’s free now. I have SketchUp and files on an SSD, 4.4Ghz Quad i7, 16GB Ram, GTX 980ti 6GB GPU. If I am not able to edit the model then you should look for another solution.

I will also try @McGordon method in Blender, I was aware of the decimate modifier but this is also really helpful for me too so thanks for pointing that out!

I am working on my Mac laptop so it’s no problem to leave me PC crunching the numbers on it’s own.


#12

You said disk usage was at 100%, I didn’t see that. Processor was at 100% for one core. It sounds like you’ve ran out of RAM and it’s swapping out to disk which will really slow it down. I can’t remember how much RAM SketchUp was using, I’ll look when I get home, but I wouldn’t be surprised if you’d ran out if you only have 12GB. An SSD would only help a bit in that the swap files would read and write faster if the problem was a shortage of RAM.

I was able to zoom but not scrolling in real time. I used the zoom window tool or scrolled by guess on the scroll wheel and waited a couple of seconds.

I tried again to get the whole file into Blender via .dae and it worked after leaving it running while I did something else. It might have taken hours. I might be able to simplify it but it ruins the look. It is really nice and smooth as it is.

I was wondering if those shapes were buildings but your explanation of trees that the drone can’t see under the canopy makes sense now.

Could you get your drone guys to process it at 1 or 2 foot resolution?


#13

SketchUp was using around 6.5GB of RAM with the full 6" contours file open.

Full 6" contours reduced with Blender’s Limited Dissolve at 25° to 2,673,352 edges, but this was not much faster in SketchUp. I then removed every 2nd layer making it effectively a 1 foot resolution contour map.
This takes it down to 1,336,570 edges which is a bit faster for me. Finally removed every 2nd layer again taking it down to 2 feet resolution vertically.


1 foot resolution, 1,336,570 edges 112MB SketchUp file


2 feet resolution 667,159 edges 56MB SketchUp file

The full resolution file took ages to export from Sketchup and import to Blender but once converted, it loads in about 1 second and zooms & orbits super fast.


#14

Thanks to the both of you fellows…I’m just getting back to this after too many distractions, but only for long enough to say thanks and that I have to go AWOL again, but will be back when time allows in a few days, probably.

Briefly, though…
I guess I should go RAM-shopping,
The host site will, I think, process at any chosen resolution if I ask them to do so. The 6" thing was a wild-ass guess, based only on my thinking back to something that the drone operator said about “mm-scale precision” being possible (which I figured would be silly regardless, given the basic visible-light/IR-blocking capacity of the jungly terrain here)…so 1’ or 2’ might indeed do the trick.

I gotta get some sleep but will check out the contours you came up with, McG - maybe there’s no need to reprocess by the host?

Mahalo - Dave


#15

See what you think when you try and work on those files I shared. They were both made from a 25 degree limited dissolve. You can play around with the angle setting to discard more or less data. If you don’t dissolve the layers but discard alternate layers you could have smooth layers that are further apart vertically. I haven’t done this but the edge count would be roughly:
6M for 6”
3.5M for 1’
1.75M for 2’
That’s a very rough estimate (just halving) as the layers obviously don’t all contain the same number of edges.

The best compromise might be a less aggressive dissolve with 3/4 of the layers discarded i.e. 2’ vertical resolution.

Your drone people might have a better way of reducing the file with a 3D resolution setting like 6”x6”x6” or 3’x3’x3’, especially if they still have the original data. A mm resolution scan sounds amazing.

I wrote a small Ruby plugin to remove alternate layers. Selecting them by hand wasn’t an option with over 900 layers.

I haven’t tried it yet, but the Sketchup Team have a plugin to help reduce vertices in contour lines. It seems to do the same thing as Limited Dissolve in Blender where you set the minimum bend angle below which the vertex gets removed.
https://extensions.sketchup.com/en/content/simplify-contours-tool


#16

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.