Can automatic model reload be disabled?


#1

I don’t know if this is new but I’ve never had the problem before.

In LayOut 2018 models are reloaded automatically each time the file is modified, which is very distracting and annoying. Every time I switch to LO I have to wait a second or two for it to be responsive (it is in my muscle memory to hit Ctrl+S every time I switch focus away from a program).

Previously LO has never done this to me. The model has never been reloaded into LO without me doing it.

Can this annoyance be disabled?


#2

I don’t think it is new.

My habit was always to open the SU file and work on it before switching to LO, but if the LO file has already been created, you have to be careful that you are editing the right SU file. @DaveR taught me to open the LO file first and then use Open with Sketchup. That ensures you get the right file. But then when you switch between SU and LO (as you do when editing presentation documents), there is a slight lag whilst the LO file updates. I guess the actual lag depends on your computer and the file size. My impression was that since SU/LO 2018, it has actually speeded up a bit.

But I expect you know all this.


#3

I always work in both SU and LO simultaneously. I change layer visibility and the like to get the drawings right, and I use my 2D drawing to get the extents for how much I should model in 3D. However, most edits I make in the model do not need to be instantly updated in LO. I only need to update the reference every second minute or so, not every 5 seconds. This is extremely distracting and makes LO nearly impossible to use.


#4

If you don’t open the SU file from LO, LayOut won’t automatically update the reference every time you return to it. It’ll wait until you choose to update the reference. Or you could untick the Auto button in the SketchUp Model window to prevent viewports from being re-rendered when you go back to LO. You’ll see the yellow triangle indicating that the reference has been changed, though.


#5

I want the viewports to be re-rendered when the model is updated, but not the model to update unless I tell it to do so.

Anyhow, what you said made me realize what the problem was! I normally never ever open models from withing LayOut. However, earlier today when right clicked the viewport to update the model I accidentally clicked Open with SketchUp rather than Update Reference. The model was already open and on the question whether I wanted to open the file as read only I clicked no. This must have attached the file listener anyway, making LO update the model when it was later modifier. After closing and re-opening the LO document automatic reloading is gone. I was very scared compulsory automatic reloading was an intended change in SU 2018 :open_mouth: .

Thanks!


#6

I’m not sure I understand. The SKP model can’t be modified or updated from LayOut. The viewports re-render when LO is told to compare the reference SKP file to the embedded SKP file. The embedded SKP file is replaced with the new reference SKP file and the viewports are rendered to reflect the changes. As you found out, you are basically telling LO to look out for changes to the SKP file if you open the SKP file from LO. If you open the model file from SketchUp’s File menu or by selecting it in it’s folder and opening it from there.

This has great power because you could replace the SKP reference with an entirely new one and as long as the scenes have the same names, the viewports will automatically reflect the change.

This automatic update thing also works for editing image, text, and spreadsheet files when they are opened from the Context menu.

I’m glad you’re all set now, in any case.


#7

What I meant is that updating and re-render are different things. Update is when the model is reloaded into the LO document. This is what happened without me wanting to. Once I have updated the reference myself I do want it to re-render.

Anyhow, the problem was that I had forgot that I almost had opened the model from within LO. Since I cancelled opening the file I didn’t think of LO thinking the model had been opened from there.


#8

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.