Bug Report: COPY does not preserve the dynamic-component layer


Just noticed that the COPY attribute does not preserve the layer of a copied dynamic component. Instead it sets it to Layer0.

Couldn’t find a plug-in or a work-around.


A year late but +1… The only thing I can think of is to nest the copied thing in a shell… which isn’t fun. But then the shell can be set to be on a layer.

I JUST ran into this same problem tonight and the shell thing is purely an idea. I agree that copies should stay in the layer of the thing being copied.

FWIW, just found a easy solution to my problem. Rather than put the copied thing in a shell as I was thinking, I nested the contents of the copied thing in one more shell and then set THAT to the layer I wanted preserved.

Which is somewhat opposite of “best practice” I’ve always taught. DCs aside, I’ve always advocated "draw everything in layer0, then group/component, then set that to a Layer. I know there are always exceptions but until this one, I never thought they were convincing enough to break the “best practice” rule.

Drill into the copied thing and then make a new group/component shell. Put that to the Layer you want preserved.

Been there Seen that. Challenge with Nesting Groups into Compos is that when editing, I almost always forget that there’s still another element on level below the Compo being revised.

Not elegant but; another option is to program Visibility (Hidden Yes/No) as part of the particular DC. Slow and cumbersome but so far, that’s an alternative method.