Bucket tool in Mac, Please help

I have a m1 pro MacBook, and I install the 2021 Version,but I found that the bucket tool is quite difficult to use , the straw tool function always too slow in the MAC ,when the file has like 100 materials ,the straw tool is so slooow , a problem not seen in Windows system. Can anyone help? Thx!

Are you referring to the Paint Bucket tool? And what do you mean by the straw tool? The Eye Dropper? Can you share the file you’re having trouble with, so we can better understand the problems you’re having?

yes , I am not good at English, and I found the problem is quite obvious when the Enscape material is in the file.

WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free this is the wetransfer link, please help.

Could you point out a particular surface that uses an Escape material? All the ones I tried picked up the color quickly.

I think it’s the problem is the color panel.When the model has a lot of materials , “color in this model” panel will be very slow, just in Mac system

Most people at SketchUp use Macs, and I’ve tried your model on my work MacBook Pro (that is Intel), and on my own M1 Max MacBook Pro. The colors in model does seem to work ok, though your model is demanding in some way that I didn’t figure out yet.

Mac with AMD graphics card seem work better than Iris graphics or M1 , the color function doesn’t
work good compared to Windows system. I have tried for several times,maybe it is the OPENGL problem?

I’m not surprised an Iris graphics Mac could be slower because that isn’t really a powerful enough graphics for SketchUp, especially with a complex model such as this (over 1,500,000 edges). Since SketchUp doesn’t yet have a native M1 version, maybe there is some subtle glitch using the M1’s graphics via Rosetta 2? As you noted, the material sampler works fine using my 2019 Mac Book Pro with AMD Radeon graphics.

I am quite frustrated when using the paint bucket tool in apple silicon Mac.Once the model is large ,the eyedropper tool doesn’t work fine, and it is hard for me to change the parameter,the function never break down no matter how large the model is. :hot_face:

I send the model to my friend with the M1 max MacBook,he told me that it doesn’t work fine even with m1 max,so I am quite confused. Maybe it is the enscape material problem, I don’t know,I have to find out what problem is,since the m1 pro is so expensive.

On Mac, if you press Command-Shift-5 you can then do a screen recording. Could you do a recording of the eyedropper not working? Then I would follow exactly the same steps, and same faces that you try, to see if I then have problems.

Ok right on it!

this is it .The eyedropper is so slow , a problem will never show in Windows.Thanks , Colin!

The example model you sent before has different scenes. Still, here is my M1 Max, running SketchUp 2021.1.2.

I don’t know why it works slowly for you.

I seem to have found the problem. The larger the texture file, the more sluggish it will be to read. In the video I just uploaded, the texture map is 7mb, but the texture of the mac with a few hundred kb will not cause problems. At the same time, I remember that no matter how big the textures on windows are, they will not be slow to read.

You may want to check out Texture Resizer on Extension Warehouse. It will report the size of all textures in your model and allow you to shrink them down.

There are some materials that are much larger than they need to be. In addition to resizing the materials as @TheOnlyAaron suggested, you might consider consolidating materials. There seem to be quite a few duplicates. Here is a screen shot of the materials in your model after I purged unused stuff. (Another thing you should be doing.)

There are some textures that could be replaced with simple colors, too. Those red swatches at the bottom of the panel are photos of a plastic bin. They could both be replaces witha single red color which would streamline things a great deal. I wonder about how useful some of the other textures are in your model such as the black one immediately after those two red ones.

Fix the incorrect tag usage…
Screenshot - 12_21_2021 , 8_24_47 AM

…and purge unused stuff from the model.
Screenshot - 12_21_2021 , 8_25_05 AM

If your model was more efficiently constructed, I expect you’d have less trouble with it as you are working.

1 Like

good solution,thanks Aaron!

Appreciate it,thx!