Blank Model Space Screen on Sketchup Pro 2020

Hi! I just downloaded Sketchup 2020 and I get a blank model space screen. My toolbar is present and sketchup responds when I draw or select, I just can’t see what I have drawn or selected. When I do a Print Preview, Laura (the human scale) is present. My Windows and Drivers are updated but still a blank screen. I already did the OpenGL and turning off the fast feedback and the antialiasing and anisotropic but still nothing. I hope someone can help me. My graphics card is GeForce GTX 1050 Ti/PCIe/SSE2. Thank you!

What type of device are you using…laptop,desktop ?
Did you right click on the desktop and use the Nvidia Control panel to tell the software to use the 1050 for Sketchup?

Changing to the Nvidia GPU should fix things, but while they are going wrong, go into Preferences, OpenGL, and turn off Use fast feedback. See if that makes Laura appear.

While you are at looking in the SketchUp Preferences OpenGL panel, see what graphics it says you are using. If it lists the 1050, you know that is what it is at least attempting to use.

yes it does list 1050 in the Graphics Card Details

I already tried doing this and lessening to 0x but still nothing

I’m using a laptop. I already went to the Nvidia Control Panel > Manage 3D Settings > Application Controlled for both Antialiasing and Anisotropic. This didn’t change the blank model space. Are you saying a different method than what I did?

Another way to force the right GPU is to go into Graphics Settings, browse for SketchUp, and in its Options choose the High Performance one.

where do i find Graphics Setting? Is that in Sketchup?

In the Nvidia control panel

I wasn’t referring to the Nvidia settings, I meant the Windows settings.



i will try doing this and update you. thank you!

wow thank you so much!! i tried your solution and the other user’s solution and the model space showed up!! how did you guys know about the fix? would this be permanent already or would i need to keep adjusting? thank you again!

thank you for helping! i tried your solution and the model space turned up complete with laura the human scale! i just wanted to know why sketchup did the blank model space? was there something wrong with my laptop? and would this fix be permanent or would i need to adjust before i use sketchup? thank you again!!