Blank Learn, Tutorial and Extension Windows


#1

Hi All,

I am aware there is an almost identical topic in the forum from Dec 17, but it has been closed without being resolved.

I have run Sketchup 2018 as an administrator and have updated video card drivers (GTX 980M - driver 417.22) and IE installed and up to date.

When I run Sketchup I get this blank image on the Learn, License and also the Extensions page:

Having read around the issue I understand this is related to how Sketchup uses the default web browser. I use Chrome as the default, but I have IE 11.407 installed.

Interestingly, when I force a reinstallation of the graphics card drivers, when it uninstalls the current driver the content for those windows appears. Then it finishes the installation, the license info is still there but Sketchup has shadows and funny colors etc… when I try to use it. As soon as I restart it goes back to as it was (i.e. blank).

Any help would be very gratefully received. I have been trying to fix this for ages and it is driving me crazy.

Not really used to using forums, so please forgive any forum faux pas I may have made in this post.

Thanks,

Pete


#2

Also, have gone into the Nvidea settings and the 980 card is set as the default for Sketchup.

Have fiddled with all the OpenGL settings in Sketchup and they don`t make any difference.


#3

Your network is likely blocking sketchup.com? Or http-only urls (which the welcome panel is). These are just URL’s that you can open in a browser. SketchUp embeds a Chromium browser in 2017 & 2018, so if you can get to Extensions in a Chrome browser https://extensions.sketchup.com/, you should be able to get to it. If not, see the posts on clearing WebCache (for the embedded Chromium browser).


#4

Hi Barry,

Thanks for the quick reply and your time. I can access https://extensions.sketchup.com/ no problem from chrome, but not the extensions warehouse from within the application.

I have deleted cookies etc… from Chrome (as per https://support.google.com/accounts/answer/9098093?co=GENIE.Platform=Desktop&hl=en&visit_id=636795669213339086-1029545813&rd=1 ) and also deleted everything in:

C:\Users\petes\AppData\Roaming\SketchUp\SketchUp 2018\WebCache\Cache

But, I still have the same problem. I’ve maybe misunderstood your reply. If I should have done something else could you expand on what I didn`t do properly? Thanks again for your time.

Regards,

Pete


#5

No, that’d be it… you do have to restart SketchUp after deleting the cache. I suppose 3D Warehouse is inaccessible as well?


#6

HI Barry,

Hmm… Yeah, I’ve restarted the laptop and it makes no difference. 3D Warehouse is blank as well.


#7

Just checking, this comment of yours can be read a couple of ways and is often the reason for errors.
The critical part of this is not that you run SU as admin, but that you install it by Right clicking on the installation .exe and choose Run as admin. If this isn’t what you meant by your comment, try it this way now and choose Repair when it gives you the option.


#8

Thanks for your reply. I did install by right clicking and using “Run as Administrator”.


#9

It might be hardware related. Power issues with the ethernet-adapter and graphic- card could cause these effects.
Try to disable the dedicated graphic card and untick ‘use fast feedback’


#10

HI Mike,

Awesome! That works. Thanks so much. If I disable the GTX 980M (Under Display Adapters in the Device Manager) everything starts to work. Seems strange though; surely I want to be using my beefy graphics card rather than the base one?

At least I can now use Sketchup and know for certain the graphics card is the issue. If anyone has any suggestions on how to get the GTX 980m working I`d be pleased to hear them.

Pete


#11

This is a long shot, but have you tried much older drivers (say from before the nVidia 10xx series became available) as well? It is probably futile, but in terms of troubleshooting it may be an option.


#12

Thanks Julian, I’ll try that at the weekend.