Black Workspace Screen - MacOS high sierra 10.13.6

First posting here. Use to work on SketchUp Make pre 2017. My MBP 2010 getting hold (like me) and I decided to work online just like I do with ArcGIS online.

Using Chrome as a Web Browser, I opened sketchup and signed in with google. All went well until I saw the workspace appear like the image below.
All the functionalities are working - preferences, toolbar, panels, status bar…etc!
It even loaded older files that I could open…but could not work on them due to the black screen workspace.

After a few troubleshooting search, I used the MAC disk utilities to do a First Aid repair. I also looked for old files like “com.atlast.sketchup.plist” and others in my cache, in order to trash them. I did not find any of the suggested old files.

Here I am! Hopefully I can get help from a “sage”. cheers

Try updating Chrome. Then power off reboot of the computer. Any difference?

Thanks DaveR for the suggestion. Tried but no change.

What you show is clearly a graphics issue. In your profile you list an old Nvidia graphics card which Apple stopped supporting a long time ago. (One of the reasons my MacBook Pro is only used to run an old scanner anymore) Can you change which graphics card is being used by Chrome to the Intel GPU? Maybe it’s had a little more love from Apple with reasonably current drivers.

Try pasting this into Chrome’s location/address field:

chrome://settings/system

What does the hardware acceleration setting show?

I was able to disable “automatic graphics switching” which forces the computer to always use high performance graphic. It still gave me a black workspace screen. Thx anyway Dave.

Here is the screen shot.

In the end, I decided to use SAFARI on my MAC to access free SketchUp. No more black workspace within SAFARI.

Problem solved but interesting work around.

I’m on High Sierra with a 2014 MBP and mostly use Firefox. I’ve not had issues with that.