Black areas showing up in 2017 Layout viewport

layout

#41

Apple released an update today that apparently solves some graphics issues. I hope it solves the problem for Mac users.
See more here: https://support.apple.com/en-us/HT207462


#42

The update released today does NOT fix the problem.


#43

@cbdavis4 and mac users. Too bad…


#44

I am facing the same problem with my imac 5k and SU 2017. It is pretty frustrating as I need this function (SU --> layout) allmost every day. Is there any hope that this issue will be solved? I did not have this kind of problems anymore since I stopped using Win. What to do here?


#45

From the way it sounds, you’re at the mercy of Apple and the authors of the video drivers that are responsible for the problem.


#46

Just had a long phone talk with the Apple service line. The specific person on the line an the technical did not know the specific problem and a sent them a copy of this (above) communication. The technical stated, that it is up to Sketchup to react an new hardware and its drivers.
So I guess both sides gave up on this problem - so if no-one tries to find a solution, I will return my Apple and will ask for my money for Sketchup 2017. Both are worthless in this case.


#47

Philipp, agree with you! Waiting for solution as well. Did you try making sky and ground white(default) color in background settings? It fixes the problem for now. You don’t have transparent background, but at lest no more black areas.


#48

Great Simonas!
That solved my problem for now! Thank you for this input!


#49

One quick note here: I found that sometimes black areas reappear even when I had white sky and ground (I had two times), just go back and put white color again and re-save it. It fixes the problem.


#50

OK, good to know - for now it worked great for me!


#51

Hi everyone,

As Marc mentioned a little while ago, we have tracked this down to an issue in the OpenGL stack for certain recent iMacs and MacBook Pros. We’ve been working with the GPU vendor to determine if the problem is in their driver or elsewhere in macOS. Luckily, we have also found our own workaround within SketchUp that we are currently testing and hope to make available soon.

Thank you for your patience and for all the submissions of system information from machines that exhibit this problem.

Thayer


#52

That is welcome news. Really looking forward to a fix. Thanks and please hurry!


#53

After latest macOS update. I finally got my transparent background back! But only on macbook pro. iMac still have same problem though…
anyone else?

here is macbook pro :


#54

Try the latest SketchUp 17M2 update released today, or late yesterday.
http://www.sketchup.com/download/all

See Release Notes:
http://help.sketchup.com/en/article/141303


#55

Fixed!! The latest release has gotten rid of the black boxes on my IMac. Finally back to normal. Thanks team!


#56

Great to hear! Thanks for the feedback.


#57

Seams the problem is reintroduced with the new MacBook Pro 2017 with the Radeon Pro 560 :frowning:

We are running LayOut 17.2.2554 / macOS Sierra 10.12.5 and we don’t have this problem on our Mac mini 2012 and our MacBook Pro 2014 with nvidea gpu.

UPDATE: problem only happen with transparant background, turn on the sky and color the sky white fixes the problem.


#58

Hi Guy-

Thanks for the report. I’ll see if anyone here in SketchUp headquarters has that video card and we’ll do some testing. Stay tuned.

-m


#59

Thanks Marc.


#60

Same issue here with the new 2017 iMac with Radeon Pro 575
We had no problems with the older iMacs with the nvidia cards.

This is with Sketchup 17.2.2554 / macOS 10.12.5

Both layout and sketchup have problems exporting pdf/jpeg files with transparent object against background/sky.