Beginner's problems in Layout

I’m an almost complete beginner in Layout though I’ve used SU Pro for over a decade and am reasonably proficient in it.

I’m trying to print to scale from SU Pro 2023.1.341. Mostly, printing directly from SU has worked well enough for me in the past, but I thought I’d try to make this drawing look a little more professional, with a border round the drawing, and a simple Title block. And SU was misbehaving when I tried to print to scale directly. When I moved the SU window border to reshape the window from landscape to portrait or vice versa - it stretched the model as well as the window, and wouldn’t revert to normal.

But…
With my model ready to print, I clicked Send to Layout.

I slightly enlarged the viewport, and eventually managed to remove the background, both in SU and in Layout.

I hid some text in the SU model, saved the model, and tried to update Layout to see the change. The text was still there in Layout. Why? I checked the Document/References panel, and the file listed has the latest time stamp.

I tried both to click the little update symbol in the Layout sidebar (left most of the two icons here)
image
and also by R click on the viewport and clicking Update Model Reference (not sure if these are supposed to do the same thing?) I had saved the change in SU before trying to update.

I tried this several times. Nothing changed in LO. Instead of hiding, I deleted the text (by cutting to clipboard) saved the SU model, and updated in the Document/References panel. That worked. Pasted the text back in, hidden, saved, and updated in Layout again. That worked - the text stayed hidden. I just don’t understand that.

I drew the title text, border and title block with the rectangle and line tools. Finally managed to work out how to put them on the On Every Page layer (R click Move to Layer…).

Found I want to move one of the small text boxes. Can I get it to move? It won’t select if I click on it, even though I have brought it to front. I can window round it, and that selects it. But i CANNOT get it to move. I can get the little hand (Pan in SU) to light up and move with the mouse, but that just moves its pivot point. I can get the Rotate symbol to highlight it. But NOT Move.

[I think I’ve just figured out why. It overlaps the viewport. When I move the bottom of the viewport up, leaving it clear of the text box, Move now shows up. But since the text box is now at the front, why can’t the mouse ‘see’ it before it highlights the viewport? Anyway, that problem solved.]

My first page, for the Ground Floor, now looks ok.

Then I wanted to add another page for a different floor (the first floor UK, 2nd floor US) in the plan drawing . I copy and paste the viewport to a new page, and change the scene in SU I want on that page.

More or less ok, except than when I now go back to page 1, that scene has changed too.

How do I make the two viewports independent? I’m probably wrong, but I thought that @DaveR had said copying and pasting the viewport was the way to prevent multiple references to the same SU model in the Layout file?

Feeling stuck on this last one, though I’ve found workarounds for some of the frustrations.

PS. Another problem. There’s still a viewport on P1, but it’s now empty, the Sketchup Model panel shows No Model Selected and the link button is greyed out. The model is still there in the Document Setup/References.

Theatre plan JWM.layout (2.6 MB)

John,

Would it help to look at your LayOut file together?

Very greatly. You helped me a very long time ago when I first tried using Layout, and I’ve forgotten much of that. I’d be free now - do you use Skype?

Or send me a link in a PM to use software of your choice.

Theatre plan JWM.layout (5.3 MB)

Many thanks again.

1 Like