Background interference when zooming/rotating scene

Greeting…
Relative newbie here, having some issues with the backgrounds of my models when rotating or zooming. I don’t recall this happening near as much with Sketchup 8 - but with this version it continues across all of my models.

As you can see from the attached, these ‘wedges’ and angles vary depending on the amount of zoom / rotation.

Any assistance would be most appreciated.
Thanks!

Not seeing the attached. Not seeing a coherent description. Not able to respond.

-Gully

Thanks Gully…
Took me a minute or so to figure out I could only upload one image at a time.
Updated.

Appreciate your time and assistance.
TC

It is face z-fighting. (Two faces wanting to occupy the same plane.) Cut out the area of the background face, or separate the front faces by a wee bit, like 0.001".

What are we looking at here? Are these native screen shots? Renderings? What does the model look like in Monochrome?

Now that the image is visible, a lucid description of what it is and what you think it shows would be useful.

-Gully

I don’t see the “shimmery,” “stripey” look of z-fighting. It looks more like the back-side of faces in a rendering.

-Gully

1 Like

I’m thinking it might have to do with OpenGL and an inappropriate graphics card driver.

Thank you all for the quick, kind response.
We are looking at screenshots of the model. It only happens when I zoom in about this close (attached). The closer I zoom, the more it happens.

It seems to happen regardless of whether a group or component. Sorry, I don’t know how to view in monochrome.

Wo3Dan… thanks for the comment. I sometimes wonder about this, but I have 32 gigs of ram on this powerMac.
Thanks.

How much RAM you have is unrelated to OpenGL support.

Monochrome is the last button on the Styles toolbar, which depicts the various screen rendering styles. Monochrome displays the bare face fronts and backs after you have painted them, so you can check for, among other things, face orientation. In this same vein, the prudent, systematic modeler leaves his model unpainted until he is satisfied that the geometry is right, rather than covering up the evidence prematurely.

Three Sages; three different guesses at the problem. Obviously, your pictures and description do not provide enough information to diagnose the problem. Looks like we need to see the model itself.

-Gully

Thanks again.
I’ve been trying to upload an MP4 for the last 15 minutes, but it gets stuck at 100% and spins forever.
Anyway, in monochrome it looks the same.

If you are willing to take a look at the model - thank you - it’s 21 mb
Thanks.

I’m really puzzled by the colored objects in your Monochrome view.

21 Mb? Hard to believe–there’s not that much stuff there. Have you tried purging then re-saving (to drop the file size)?

Winow > Model Info > Statistics > Purge Unused.

Are you using layers? If so, how?

-Gully

Imported and unexploded images?

@TheChizz, if purging the file of unused entities doesn’t reduce the file size enough, upload it to the 3D Warehouse and give us the link.

Thanks… just purged, brought it down to 14 mb
The colored objects are imported graphics (png files).

One layer.

Dropbox link
(https://www.dropbox.com/s/nctsmb6dv49d3gs/M7-Small%20FootprintB.skp?dl=0)

Thanks for your time.

According to model info statistics, there are 42 images in the model. Unless you were careful to prune them down, that is sure to run up the size of the model.

There is z-fighting on the wall in this screenshot, but otherwise I am not having any issues with zooming or orbiting the model on my MacBookPro Retina.

Well, the colored objects are indeed unexploded images. You’ve got a bunch of reversed faces, which don’t seem to be the problem. No z-fighting (except as observed by @slbaumgartner) . No clipping.

Going all the way back to your first screen shot, I don’t see any of the triangular artifacts.

Maybe Wo3Dan is right about your video card. To confirm that, try going to Window > Preferences > OpenGL and turning off hardware acceleration. What happens?

-Gully

You say you have a PowerMac. If correct, that computer uses a PowerPC CPU and is at least 10 years old. It wouldn’t be too surprising if its display adapter is not up to the requirements of current versions of SketchUp (I didn’t even know that SketchUp 15 could run on a PowerPC!).

Sorry… it’s a 2009 MacPRo.
OpenGL was not engaged.
Some time back, I was having issues with LightUp and if I recall, was instructed to turn OpenGL off.
Using hardware acceleration eliminated the problem :slight_smile:

Although like slbaumgartner - that one wall still causing issue. Would that be something of the way I am using the graphic as texture…or…?

Thanks for all the quick responses and your assistance, much appreciated.
-TC