Autosave is consuming 25 % to 35% of my time using Sketchup Free

Is there a workaround for this issue. It’s tough to get much done in the way of drawing with so much time consumed in saving. Thanks.

Maybe the Autosave process could be a separate thread that works in parallel with the main Sketchup process so that it doesn’t cause everything to freeze up until saving is complete.

This is one of those issues that doesn’t happen to many people and hasn’t been pinned down to a specific cause, as far as I know.
One option would be to try a different browser and see if that works better.

I’ve been using Sketchup free for a LONG time with much bigger files and NEVER had this issue with autosave. Then as I recall some weeks ago Sketchup free was unable to save files to the cloud at all - for maybe a day or two. It advised you to save them locally. Then that bug was fixed - only to see the repetitive autosave re-appear as a bug - its mentioned in 2017 and 2018 as a bug and which was fixed.

With that fuller explanation of your problem someone else may be able to offer a solution.

Ok well thanks for your help Box. I hope they can fix it cuz I really like the cloud based Sketchup concept, the solid tools kit, the better resolution and so on :slight_smile:

You may well be correct in that there is an issue on the sketchup end that needs fixing, but there could also be other things causing your problems. Personally I’d be checking other things like using a different browser or browser settings etc in case the issue is on your end.

Ok I will try a different browser as you suggest and post the result. Thanks Box.