AutoCAD to SU Import - Preserving drawing Origin


  1. I isolated all necessary layers in AC and saved as separate files.

  2. I want to import each layer file separately into SU so they arrive as a group

  3. I started importing LotLines first, then Contours

  4. Even with Preserve Drawing Origin checked the Contours file imported very far from the LotLines file import, as did other files

  5. Screen shot and LotLines, Contour files included here along with SU test file.

Would anyone have a suggestion on what I’m doing wrong on this?


xref_LotLines.dwg (21.9 KB)

xref_Contours.dwg (30.9 KB)

TEST 1.skp (68.4 KB)

Either the Preserve Drawing Origin was not checked when you imported LotLines, or the files have a different origin point.

BTW, you are using some wrong import unit, perhaps inches instead of feet. However, using the Preserve Drawing Origin option with a larger import unit may result in your model ending up far too far from the SketchUp model origin to be practicable.

Agree with Anssi… its most likely your base autocad drawing… do you have multiple UCS coord systems in your dwg/s ? Or you missed toggling preserve base coord or assumed wrong base unirs on import, all simple to correct…

Hello Anssi

I checked import unit and that is inches.

Preserved drawing is checked.

Although, when I check preserve drawing origin SU notes 'undesired result may occur when checking this option’ - certainly true.

Will talk with my instructor tomorrow to see if she has a fix.


Thanks gSharp. I’ll get back to you tomorrow with some answers. AC knowledge is limited, so some research via my instructor might clarify my issues.



Daniel O’Kane

CAL LIC #1038951

judging by the two dwg files I suspect they have different coordinate systems (local UCS and global USC) active when imported into SU.

When I imported both files, making sure that “Preserve drawing origin” was checked for both, they got placed neatly on top of each other.
Untitled2.skp (141.1 KB)

Thanks Anssi. I think I’m missing something or barking up the wrong tree.

Also, any idea why both files import so far from origin point, even though you specified ‘preserve origin point’? From your file I had to zoom extents to view up close. But not an issue, just wondering why this occurs? Thank you.

Thanks g. Still working out the issue of what I did wrong or perceived to do wrong.

It is the AutoCad origin point that is preserved. The option places the AutoCad origin at the origin of the SketchUp model. The origin in your DWGs is far from the content.

Thanks for the help. I think I got it sorted with y’all’s help. Thank you!