Auto-Invisible Layer not working in SU2019! Bigly Sad!

Any good work-arounds or options out there? I will often add a layer after I have many scenes created, and this extending was very handy.

Did you try it? I have it installed in SU2019 and it works fine despite what it says in the EW.

Maybe you’re “bigly sad” for nothing.


Those version compatibility items are set by the extension authors, not based on any test by Trimble. Unless the author bothers to update them, they don’t necessarily mean anything.

1 Like

It’s a pure Ruby extension and should work in every new SU version unless Trimble makes a breaking change to the API, which they avoid as much as they possible can.

Correct you all are. I tried several times yesterday to install it with no luck, but succeeded today. Probably I was making an installation error or being impatient. It is a very useful extension.


Has anyone successfully loaded Auto-Invisible Layer in SU 2020? I seem to be having trouble.

Yes. And it works fine in SU2020 although it still refers to layers instead of tags but that’s no problem.

Yes, Running it on MAC like you, works fine as Dave said.

Great- I will try some more. I was getting a “will not install” message. Related question: I am embracing using Outliner to control object visibility and finding is very useful, particularly since is requires me to create far fewer Tags. BUT, If I make a new object it will automatically be visible in all Scenes (or if nested in all Scenes where the parent object is toggled visible). This then creates the laborious task of updating all Scenes, a problem which Auto-Invisible Layer nicely fixes if you only want this object to show up in a few Scenes. I suspect the answer is no, but is there a work-around that does not entail making a new Tag? Thanks

I’ve never seen that message before. How are you trying to install it?

Fourth time is a charm, apparently. I restarted everything and tried again and, et voilả. I have no idea what the hang-up was.