Apple help urgently required! Login is not working - really need help so I can work this weekend

At 2:21 this afternoon, I was logged out of Sketchup and now cannot open a file or do any work. Something is not connecting my login through my browser (Chrome) and the system on my machine. I have 5 deadlines due next week and was going to work day and night this weekend. I’ve lost the second half of the day today and I’m at my wit’s end.

I wish there was support for this application. I would gladly pay for it.


Quit all instances of SketchUp.
In Finder, go to:

~/Library/Application Support/SketchUp 2022

and delete the file called ‘login_session.dat’

Restart SketchUp from the Application folder.


It’s helpful to hold down the Option key and pull down the Go menu and that Library folder magically appears in the list.

I’ll do this now! Thank you and I’ll let you know if this works!

OH MY GOSH, IT WORKED!!! Thank you! I love you.

1 Like

I have almost the same problem with my SkpPRO on Windows 11…
Even if I login through the browser, it doesn’t find it… So I can’t install VRay

Almost or actually the same?

Do what @MikeWayzovski said and delete the .dat file.

Screenshot - 1_1_2023 , 9_56_10 AM

I still have the same issue when starting… License cannot be validated. This is the log;

E, [2023-01-01T16:01:28.674495 #7440] ERROR – : SG9zdCBJRCBkb2VzIG5vdCBtYXRjaCBvbmUgd2UgZ2VuZXJhdGVkOiA3NmNk

W, [2023-01-01T16:01:44.307824 #7440] WARN – : UHJvYmxlbSB3aXRoIHZhbGlkYXRpbmcgbGljZW5zZS4gUG9zc2libGUgY2hh

If you go to and sign in there, what products do you have?
Presuming that you have bought a plan with that email address, what product access has it in the Member section?

Sketchup Free and Sketchup PRO

V-ray is not included in those plans, you can try starting a separate trial for V-Ray, but if you have trialed it before, it won’t work, either.

V-ray needs a Studio subscription, or to be separately purchased from Chaos.

I’ve installed the trial. Now VRay is working (but with very bad graphics) but I still have trouble with my license.
This is very disappointing indeed!! I had this issue for months, now, and I can’t waste any more time with that!
Even deleting the login file doesn’t solve anything…
I’m a little bit frustrated and I’m regretting having already renewed the subscription…

Found the issue!! Was a plugin making all the troubles…
Also solved the 3D Warehouse not finding the internet connection!
Back to work!!

If you would be so kind to share with us what extension was the culprit, it could help others with the same problem.
You could also contact the author of the extension so he/she can maybe do something to solve the problem.