Airfoil importer


#1

I just tried using the airfoil importer for the first time. I click on “Airfoil Importer” in “Extensions”, select the file, and nothing happens. Am I supposed to do something else?

The file I am trying to import is e836.dat from http://m-selig.ae.illinois.edu/ads/coord_database.html


#2

Where did you get this “airfoil importer”? I would suggest contacting the author.


#3

Sorry. Airfoil Data Loader.


#4

But where did you get it? It’s not listed in the Extension Warehouse nor in the Sketchucation Plugin Store. A short search turned up thislink which indicates it’s obsolete.

Maybe you need to be replacing it.

You could try opening the Ruby Console before you attempt to run it and see if it gives you any sort of error message.


#5

Your profile tells us you are using the web version, so no extensions should work anyway.


#6

Box is correct. At the very least your profile is misleading.

A lttile further research after the lead given by the link I shared in my last post shows that NCGen is the replacement. You can buy it here.

As I told you yesterday, you should be contacting the author.


#7

There is no author listed. I have NCGen, but the tutorial video shows them using the Airfoil Data Loader I am trying to use. The tutorial is from 2013.


#8

Has it occurred to you that since Airfoil Data Loader was listed as obsolete in January of 2015, that it may not be compatible with newer versions of SketchUp? Obsolete would imply that the author isn’t updating it anymore.

Did you try running it with the Ruby Console open?

There’s surely an author listed in the header of the RB file. You might open that in a text editor and check.


#9

I have no experience with the Ruby Console till now. I just tried that.

What I got was

Error: #<ArgumentError: Duplicate points in array>
C:/Users/Saulius/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/airfoil_dat.rb:41:in add_face' C:/Users/Saulius/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/airfoil_dat.rb:41:inairfoil_dat_main’
C:/Users/Saulius/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/airfoil_dat.rb:49:in block in <top (required)>' SketchUp:1:incall’

And I have no idea what that means.


#10

Is that all of the text in the console?


#11

Yes. I cut and pasted everything.


#12

Well, there may be other issues but the first line of the message points to duplicate points in the source file. Try editing that file to eliminate the duplicates.

Before you spend anymore time kicking a potentially dead horse, look for the author in the header of the RB file and try contacting them.


#13

I’d also look at what it is you are expecting this extension to do for you.
There may well be simple ways to reproduce what it can do, considering it’s age.
Show us what you need and we can probably tell you how.


#14

Thats all the information I can see on the extension.

I am working on hydrofoils and windsurfing fins. I am using airfoils from the UIUC Airfoil Data Site. What I have been doing is using the .gif images, converting them to .jpg to import into Sketchup, then tracing them. But I have trouble getting it precise and clean enough, and I get flat spots on my foils. I am trying to just import the data files, instead.


#15

That’s not the header of the RB file. Find the RB file in the Plugins folder and open it in a text editor.


#16

Here’s a very rough version using bezier curves that can be edited as much as you like. Did this before reading your last post.
Simple%20wing

You should be able to build what you want with Fredo’s Beziers Splines and Curviloft.


#17

I can only find a folder called ifcplugin and it only has dll files.


#18

I will try that technique combined with the .jpg image from the coordinates database.


#19


E836

I copied the coordinates from the dat file and put them in a txt file. Added a 0 for the x values.Then I used Cloud from the Sketchucation Extension Store to import the points and Eneroth Point Connector to connect them. Since the foil is symmetrical I only imported the points on the positive side and copied the resulting curve.


#20

I do remember that this (importing airfoils) was discussed before.
I didn’t go through this tread again like I did in the past but it may still be interesting reading:
https://groups.google.com/forum/#!topic/SketchUp3d/aIZaovyIHjA