After Windows 10 Upgrade, SketchUp Make does not have Component/Make Unique option

I am building a carousel for a class. One of the Horse components needs a unique saddle. So, I XX-clicked the entire group to edit, then XX-clicked the single Horse, then R-clicked it. There is no longer a ‘Make Unique’ option in the list.

Last night was a Windows 10 update that lasted hours. Now lost ability to save directly too.
Can somebody help?

Much appreciated!
Meg

Sounds like you just need to single left click that horse, so that it highlights blue, then right click for the context menu which should show make unique.

You don’t need to go into edit mode to make unique.

If the entity you clicked on is not a component or there’s not more than one instance of the component in the model, Make Unique will not be offered in the right click menu.If you’ve opened the component for editing, then you are selecting the contents of which wouldn’t be the component.

Perhaps you could share the SKP file so we can see what’s up.

Thank you, but I had to double-click to isolate one horse from the grouped horses, then R-clicked on it. Same result.
I don’t know how to load the file yet to show. Let me do that first.

7th icon from the left in the row of icons above where you type your text is the upload button.

If it’s more than 3Mb, upload it to the 3D Warehouse or to Drop Box and share the link.

Total newbie. Here it isCarousel_meg5.skp (2.1 MB)

I was trying to change just the saddle of the horse directly in front center, as evidence I know how to R-click/ 'Make Unique/ and choose a new material or color.

OK. I see the carousel and the horses. I don’t know which one you are calling front center.

As far as I can see, the saddles aren’t components so they can’t be made unique from the rest of the saddles. You can make the entire horse component unique, though.

I sent you a PM.

Thank you, Dave,

Red axis is completely horizontal to R side, Green axis is angled down to L just behind the horse’s hind legs. The horse on the outer ring at the center of that view is the one. Actually, any single horse of those on the outside ring is fine to make unique.

The saddle does not need to Made Unique, but in order for me to make only one saddle of that unique color, this single horse needs to be Made Unique for me to apply a different color to its saddle.
Thanks

So you need to select the horse and make it unique.
Screenshot - 1_20_2018 , 3_33_38 PM

Your nesting structure shown in the Outliners is like this:

58 PM

You need to be clear what level in the nest it is that you want to make unique! The groups will automatically become unique if you change anything in one.

Oh, wow… I just did it on mine, too.
Thank you! : )

1 Like

You are opening too deep, select only the top level component shown in the outliner and make that unique. That would get it done.

Sweet…
Thank you for this, too.
I just clicked in too far!

You guys are great!

Ian,
You guys must have hit that answer button all at the same time.
This makes my day… I felt so alone… : )

Do you have any idea why I cannot save over the file after making edits or continuing to build?
I have to keep adding a different number on the file name.
The icon for saving spins as though it is saving, but there is no new time stamp.
This started happening last night, and apparently while Microsoft was updating something that I didn’t know about at that moment.

Any ideas?

When you installed SkethUp did you right click on the installer and use Run as administrator? Weird things happen when you don’t.

Thank you, Dave,

I believe so, I’m the only one on these two computers. No problems like this have occurred prior to last night. The first indication was an exception Error “0”, like it could not find the file to save.
This problem only started last night when Windows 10 then went into a long update.
Several restarts and hours later: still no saves over the file, directly.

This morning there was another period of updates.
After that, I shut it down completely. Rebooted an hour later. I still can’t save by any direct means… can only SAVE AS.

Even if you did originally install SU using R-click “Run as Administrator” it might be worth doing it again.

Find the installer .exe file, R-click on it, and Run as Administrator. Then choose Repair.

It sounds as though Windows isn’t giving SU permission to overwrite an existing file in the folder you are saving to. Or maybe it’s making it Read Only somehow?

Have you looked at the file permissions of freshly saved files in that folder, and permissions for the folder itself?

Is it a ‘normal’ folder, in Documents, for example?

Hi John McC,

I’m not sure how to do that.
Your insight is welcome…makes sense that Windows 10 did something.
I am not a PC person, but can re-install it. I should check with the school I’m in because the original install didn’t go exactly as they described it. Yet there had been no problems operating the software 16 days.

I’m hoping to limp to the finish line as is, since the FINAL is only days away.
at least I can Save AS right now.
But I’ll be back in a few days after trying that.

Thank you!

It’s a while since I used Windows 10. But I’ve just looked on a Virtual Machine Windows 10 I have, and to see if a file or folder is marked Read Only, right click on it and choose Properties.

If there’s a check mark in Read Only on the folder, that means that any files written to that folder will be read only, and so SU couldn’t replace them when doing a Save.

If the Read Only check box has a black square in it, that means some files in it are Read Only. Click once or twice to clear the check box - no tick mark, no black square.

Once the the Read Only symbol is cleared, click Apply, then Apply to files and folders, then OK.

That MIGHT fix the issue, but doesn’t explain how it arose.

1 Like