Accuracy Of Measurements

When I create geometry, the measurements come out with a ~. I have model info set to 1/64" (display). This is for the display only, right? When I create a line that is, say, 20’. Entity Info reports, ~20’. Should Entity Info report the actual measurement of the geometry?

When I import a DXF file and scale a line that is 5’, and am asked to scale all the geometry (yes). The line measures 5’ 1/32". Should it not be exactly 5’?

What am I missing? Thanks …

1 Like

Is ‘Length Snapping’ turned off?

Under Model Info > Units > do you have enable length snapping off? Best to keep it off. Yes the display precision is for display only. Can you upload the file in question, it would be easier to see whats going on.

The re scaling of a line as you describe should make that line exact, perhaps the entire line was not selected at first. have to see the file.

If you make a line and type in 20’, entity info reports something else besides 20’?

Yes, turned if off.

So, it seems the ~ issue is only with geometry in imported DXF files. If I create a line in a new SU file it reports a measurement without any ~'s.

The left line in the video is from an imported DXF. The right one is created with SU, no problems as seen. However when the left one is resized via the tape measure tool, it continues to report, ~20’, all other geometry in the imported DXF also display with a ~. And while the resize does provide ~20’ on the one line, others are off by various amounts (1/16" to several inches).

Tried several DXF files, all seem to display the ~ on measurements.

I have included the SU file.

measure.skp (74.8 KB)

Turn up the precision of your units in Window Menu->Model Info->Units to see the difference in the lengths of those two lines. The one on the left is 240.013693 inches and the one on the right is exactly 240 inches.

That makes sense, eg. the ~.

But, why did the resize model not yield exactly 20.0’ ?

Forgot to add, the 240.013693 was after the resize model command.

It wouldn’t resize for me either until I did it twice, resized to e.g. 30’ then 20’ and it was exactly 20’ then. I don’t know why, maybe it ignores the resizing if the difference is very small.

You model still had length snapping turned on, by the way. Not that it made any difference to being able to resize that line.

This may very well be the case. This also happens with the"Move’ tool with very small displacements. Workaround: move away and only then into position.

1 Like

I tried 5 consecutive “resize model” attempts. Will not change. Still reports 20’ 1/64".

If your resize worked, did the line on the right change to something different than 20’?

Inconsistent stuff like this makes me crazy. :crazy_face:

I guess the moral to this story, is you just cannot trust the accuracy of imported files (maybe just DXF)?

The other moral would be that in the real world, a 32nd or a sixty-forth are beyond reasonable expectations for most construction (the exception might be furniture and cabinetry).
So just set you dimensions to the nearest eight or sixteenth of an inch.

1 Like

I wonder about the accuracy of the source file. When I draw in my 2D CAD program, and then bring it into SketchUp, there’s no problem with ~ on any measurements. Also, it just imports at the right scale, it doesn’t need the tape measure tool to get the scale right.


Ah, you have the luxury of controlling your source files, since you create them. I get my DXF files from many different sources and cannot be assured of the accuracy and/or how they were created. That said, up to this point I assumed that after scaling the geometry, after import, I would have control of the accuracy (no longer).

Ok, then I suspect the problem is a perfect storm of two things:

  1. The source material has inaccuracies
  2. @McGordon is probably onto something with scaling not working for numbers very close to 100%

Yes. I resized (via tape measure and new typing value) to 30’, then resized again to 20’ and got this. But only after I set the display precision to 1/64" to see the missing 1/64th, it is currently set to 1/16" on the downloaded file, so it rounds to 20’. Length snapping is also still enabled on this file, FYI.

Yes, it changed to 239.986308"

You may well have inaccuracies in the DXF file. If you don’t turn up the display precision of the units in SketchUp, you won’t see them. If you find that you can’t get everything to scale at once, you might have to redraw some parts. Like if scaling one dimension breaks the accuracy of another one. Maybe it wasn’t drawn accurate in the first place.

Sounds like the original DXF has lower accuracy than SketchUp.

1 Like


1 Like