About modeling and vertex snapping

snap

#1

Hi everybody.

I’m doing and exercise about modeling a PC mouse, this is supossed to be almost the final result.

it stars with a shape like this converting ONLY the three profile curves into a group.

To make the exercise easy to me, and trying to understand why it doesn’t work for me I decided to start with a more sinmple shape, like this:

The problem is … after pulling the yellow face for first time is supposed I should be able to snap the new face created just selecting the new face and using scale to snap or make it coincidence the new face with the three profile curves, like this (it doesn’t talk about moving and autofold, so it’s just scale tool):

The problem is … I can scaling it on a aproximation size that matches with the profile curves, but they don’t snap perfectly. So my question is, am I doing something wrong? maybe Model Info > Units?

This is my file if it helps.

exercise_mouse.skp (85.2 KB)

All kind of answers are welcome, thanks in advance.


#2

When using the Scale tool, select the handle, hold Ctrl (Option/Alt on Mac) to Scale About Centre, and drag to size. If you move the mouse pointer while you are dragging, down to the line, it should snap there - at least to a segment end point if not anywhere in the line. Not at my computer at the moment so can’t try it yet myself.


#3

@john_mcclenahan

Thanks, but it’s what I’m trying, maybe it works for simetric and sharped shapes as mine in which you can make a difference on every single segment, but it seems not to stick correctly at all in the exercise.

I’ll keep trying.


#4

It stil doesn’t match perfectly, in this case for the top profile curve on the third pull.


#5

I wonder if it really has to match and get stick perfectly or it’s only an aproximation.
Model info units propertis has not to do?.

I get some problems during the process


#6

It works for me at least if I snap to segment endpoints on the curve.

And even if I don’t, though it’s a bit harder to get an exact snap on the line.

The problem you are seeing of part of your model disappearing is caused by ‘clipping’. Zoom Extents, and change to Camera/Perspective view to fix.

Search the forum for ‘clipping’ to find out more.

If you have checked ‘Enable length snapping’ there, uncheck it.


#7

thank you @john_mcclenahan

This is supossed to be the final result.

And this one is mine using … different methods, starting with a circle, making it ovale, cutting the frontal side with a straight line and pulling from the face and scalling, the inward face has been done with a cilinder with different on each side and exploding the circles, then intersecting the faces.


#8

Ok, I got it in the way it’s supossed to.

I attach the file if someone want to take a look.

real_exercise.skp (250.3 KB)

Thank you all for helping me.


#9

As the book tells, it also works for another kind of shapes (if someone is interested).


#10

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.