"765: unexpected token..." warning

Since last Friday, I get this message when opening a new model. Even in a fresh blank model session, this message comes up. I believe it started happening after I imported a 3D dxf model of a faucet. But it’s weird that it pops up with a new model session, isn’t it?

Any ideas on how to purge this annoying message?


Do you have Estimator installed?

See this thread: Sketchup Pro 2019 Error on Starting

I do. But just the PDF importer extension.

Yours and Mike’s are the same error. His was due to Estimator.

Ah, ok. Reading the thread now. Thanks @DaveR

1 Like

Hi @Velina

This appears to be the same error as I get, which started at the same time as yours.

John Brock, the Developer of Estimator for Sketchup, is aware of this, and so hopefully the problem will be solved soon.

Kind regards


1 Like

Hi @Velina and @DaveR

I’ve heard back from John Brock.

At the end of last week, the company which maintain the Estimator Shop changed some code on the part of their system which checks the licenses, and as a result, broke the code link to Estimator causing the error to show up, which affects Issue Tracker.

Apparently they are sorting the fix out.

Hope that helps.

Kind regards



Hey Mike, thanks for that update.

Hmmm, this error has started popping up today again. Every model I open gives me this message. I just started another topic on this that may be erased by the admins if you wish. I had forgotten I posted this issue last May. Should I email the developer of Estimator for Sketchup and report this?

Yes please

1 Like

I heard back from the developer, this is what his email said:

"Hi Velina,

We are trying to resolve this new issue that started today. Indeed similar to last year. We updated our website to https vs http for security and that conflicted with the code somehow. Trying to resolve it promptly and I apologize for any inconvenience.

John Brock"

1 Like

Hi @Velina

Just to let you know that I have heard back from John this morning, and the problem appears to be fixed.

I have tried Sketchup a couple of times and have had no problems today.

Kind regards


It is fixed for me as well. That was quick. Be safe!!