3D Warehouse is not syncing or loading any material - please help!

I am using Sketchup Pro 2018 on a desktop MacOS Mojave. The sketchup 3D warehouse will not load, or register anything entered into the search bar. I’ve attached the screen I get whenever I open 3D warehouse. The extension warehouse works, so I am not sure it is an internet connection issue. Does anyone have any experience or advice to offer?

Thank you!


Can you try posting that screenshot again?

Can you go to 3D Warehouse from your browser, outside of SketchUp?

Yes, I am able to access 3D warehouse from the browser, and download models from there. The process is lengthy though, and I am hoping to cut out all the extra steps, if possible.

Thanks for the screenshot. We’ll see if we can figure out what’s going on. We are on skeleton crew today due to the holiday, so Barry may need to follow up tomorrow if I can’t figure it out today.

Your forum info says you’re on SketchUp 2019, but your message indicated 2018. Can you confirm the version of SketchUp you’re using and also your computer and the screen resolution you’re using?

I just noticed the pixel size of the image you posted was 4094x2090, which is pretty big. Can you try shrinking the 3D Warehouse window to about a quarter of the size and let me know if that changes anything?

Thank you for your help! I am working with Sketchup 2018, in an iMac Retina 4k, 21.5 in, 2017. My screen resolution currently is 2048 x 1152.

I tried shrinking the 3D warehouse window, but that had no effect.

You’re welcome!

I will try a few things on my end but I think this one will need Barry’s help. I suspect it has something to do with the style sheet associated with the 3D Warehouse dialog. Sorry, but please use your browser for now, until we figure this out.

Thanks Rebecca. (I hope that’s you name…) :slight_smile:

Yes, it’s Rebecca. I appreciate your willingness to look into this for me!

My pleasure. Thanks for your patience and understanding Rebecca!

Search the forums for clearing WebCache, and then restart SketchUp.

Barry, I have tried that, to no avail.

Specifically this post: Extension Warehouse lockout

Goodness. I am familiar with Windows, but I am new to MacOS. I’m having trouble finding this trail with the Mac operating system:

/Users//Library/Application Support/SketchUp 2018/WebCache

I may need a little more guidance, I’m sorry.

In Finder there is a Go menu. The Library folder is usually hidden from the user, but if you press the Option (Alt) key it will appear in the list, and you can go into the user’s library. Once you’re in there you’ll see Application Support, etc.

The way you wrote the path is missing a bit. The user’s name would normally be in there. So for me it would be:

/Users/colin/Library/Application Support/SketchUp 2018/WebCache/

Another useful trick to know is that ~/ is a shortcut to the current user’s folder. You can write that same path as:

~/Library/Application Support/SketchUp 2018/WebCache/

and it wouldn’t matter what the user’s name is. There is also a contextual menu that lets you select the text of any path, and have that location opened up for you in Finder. Like this:

1 Like

That did it!! Thank you so much for your step by step guidance, I really appreciate it!