3D Warehouse does nothing, literally

I have tried every single trick SkUp Community, Youtube or I can think about. I have uninstalled SkUp and tried again, I have upgraded Chrome, Clear cache and cookies, turn off my virus protection, adjust Security Settings, check for firewall, try different WiFis, DNS cache, try different browsers, check the availability of internet ports, try going to BING and then the 3d Warehouse (I can open it on my browser, just not on SkUp), and the “OnlineTestURL”: “”,

Nothing works, I just don’t have access to the 3d Warehouse. I can open the extension warehouse but that’s it.

I was using it one day to render some scene and the next day it just didn’t worked, even at my office, the IT guy coudn’t think of something. My boss’s starting to believe I boycoted it myself!


Does 3D Warehouse give you models when you go via a browser? Does it only fail inside SketchUp?

Hi, thanks, yes, the problem is only inside SketchUp, it works perfectly on any browser. I´ve been downloading them and adding them to my model but it´s quite slow.

Your screen recording isn’t working, so I can’t tell what goes wrong. Do you see the 3DW window in SketchUp? Does it fail while trying to download?

1 Like

It does nothing, it doesn’t show a blank page like to others or dislplay an error message, I click on it and nothing happens. Somethimes the loading cyrcle appears next to my cursor but then nothing.

When in doubt, yeah, just use your credentials to login to the 3DWarehouse website and download from there.

It is rare with the 3d warehouse but it may be that the window is opening off screen.
Try, click the icon, then alt and spacebar together, then tap m followed by any arrow key, then without clicking move the mouse around until the dialog appears on screen, click to finish.


You could also try “Cascade windows”.

Right click the task bar, and select cascade windows.

If you use multiple displays but have recently switched back to a single display, this option may not work for you unless you are sure to have your projection set to “PC Screen Only”

Hit Windows Key + P then select the above option.

1 Like

Thank you!!! Your advice worked!!! :raised_hands: :raised_hands:

1 Like

Thanks, I do use a monitor at work and I knew about this but it didn’t worked, thankfully Box’s advice did!! Thank you for helping.

1 Like