3d Printing from SketchUp for Schools - Scaling issue


#1

I’m trying to build up the tool chain so that my middle school students can use SketchUp for Schools for their 3d printing projects. I am able to export .STL, but when I open the .STL in my slicer (Matter Control) the result is scaled down to 10% size.

For example, my basic open-topped test box, a cube drawn to 50x50x50 mm appears in Matter Control as a 5x5x5mm cube. Although I can work around this by drawing everything 10x actual size, this is really not a complication I want to add for my 6th graders.

Any ideas?


#2

And I have a tentative solution…

I originally drew the test object with the length unit format default set to decimal inches, but typing metric units in the VCB. (50mm,50mm) when drawing the base rectangle and extruding it to 50mm height.

Without redrawing the object, I changed the default length unit format to 0.0mm in the Model Info menu.

I then re-exported the file as .stl, opened it in matter control, and found that it was properly scaled.

I have no idea why that made any difference, but I have occasionally run into a similar glitch when exporting .stl to and from other applications.


#3

STL files should be unitless. When you import the file into your slicer, do you have the option to set the import units?


#4

“STL files should be unitless.” Yeah, that’s what I thought. I’m not finding an option to change or select import units in Matter Control, but that may mean I have not looked hard enough.

Always more to learn, but I have achieved today’s main objective, drawing an object in SketchUp for Schools and successfully sending it to a 3d printer, which is properly printing the test object right now. I just have to be sure to emphasize the importance and value of setting the default length unit format generally, even if it shouldn’t make any difference for this. The main thing is that I can now drop the the TinkerCAD unit and expand the SketchUp unit to facilitate 3d printing and that makes me happy.


#5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.