2020.1 Upgrade Install Folder Problem

Hi, I’ve just tried upgrading from 2020.0.373 to 2020.1 and the installer won’t allow me to override its default of C:\Program Files…, where the previous (2020.0) installation was, and is, in D:\Program Files… The dialog doesn’t have a folder browse, anywhere, and just shows the Install Language option (which is picking up English US, as I had before).

I can’t install on C: so this is a showstopper for me with 2020.1.

Thanks in advance for any suggestions.

Hi Steven,

The installer is supposed to pick up your alternate installation directory, and allow the upgrade to proceed from there. There are two possible problems:

  1. Did you install to C:\Program Files\SketchUp\SketchUp 2020, at some time, and then remove the directory without running the uninstaller?
  2. There’s a bug!

To work around the problem, please uninstall the SketchUp 2020 using the Control Panel. If there are additional 2020 entries, try uninstalling them too. Then do a “clean” install, and you should be able to change the directory to your desired location.

Sorry for the trouble, and we’ll start an internal bug to determine if we can reproduce the problem.

Thanks,
Bill

Hi Bill,

Thanks for the response.

  1.   No, I only ever install to D: drive …except with annoying Adobe stuff that doesn’t give you the option! Sketchup 2018, 2019, and 2020.0.373 were all installed on D:. It is possible that I pressed Next on the dialog in the installer and then used the Back button before actually doing the upgrade installation, when I realised it was about to put 2020.0.373 on C: as it didn’t pick up that 2019 was on D:. I.e. I invariably have to override the default it suggests. I did not pull out anything directly, or via the uninstaller. I just put on 2020.0.373, telling it to go to D:, and then the 2020.1 update without any fiddling about. I didn’t get anywhere with the upgrade as it showed C: with no option to change it, so I cancelled out of it without doing anything.
    
  2.   I think there’s a bug ;-)
    

As you suggested, I uninstalled 2020.0.373 via Control Panel and reinstalled but went straight to 2020.1 (I was expecting it to fail as I saw a note somewhere that .1 is just an update and not a complete install. However, the download is about the same size so I thought I’d give it a try, and it went on fine.)

I’ve noted previously that the installer says “Saving license information”, but it generally comes up as a Demo. Perhaps that “Saving…” message is inappropriate when it’s upgrading from 2019 to 2020.0? It gives the impression that it will come up with a non-Demo license, but it didn’t when I upgraded from 2019 to 2020.0.373.

Rather to my surprise, uninstalling 2020.0.373 and then putting 2020.1 on as a full install, did pick up the license key I had entered to 2020.0.373. That was a pleasant surprise :slight_smile:

Incidentally, it would be much nicer for users like me, if I was able to edit the “C:\Prog Files…” path, directly, rather than having to go through a browse to the D:\Prog Files\SketchUp folder, make a new folder, having to type in “SketchUp 2020”. If I could just overwrite the “C:” with “D:” at the beginning of the path, and have the installer make any folder(s) that don’t exist, that would be what I’d prefer and expect, honestly (he says, speaking as someone that ran a s/w development team for decades!).

Cheers,

Steve.

Thanks very much for the information, Steve. I think we have enough information to duplicate your problem and then we’ll be able to work on a fix.

I’ll also enter an internal enhancement request to allow direct editing of the install directory.

I’m glad you got it worked out; I’m sorry for the trouble and extra steps.

Thank you,
Bill

1 Like

OK, thanks for the response.

Cheers,

Steve.

I’ve had the same issue. Have never installed to the C drive and it did not automatically pick up my previous installation to a different drive.

Didn’t go through the process of cleaning out all other possible markers/installs/versions etc. and just installed to the C drive, because I can, but I will hopefully be able to move it on the next update.

1 Like

Same problem like I have. I had installed also on drive d: and could not change the installation path/folder.
Karel

I started this thread when upgrading to 2020.1 and did the workaround advised to use Control Panel to remove the previous version and then do a fresh install. Now, upgrading to 2020.1.1, I get the same problem, again! It does rather look like the installer is simply failing to pick up a previous install path when it’s not C: ? It is getting rather tedious if I have to use Control Panel each and every time.

The 2020.1.1 update was mainly to solve a crashing issue on Windows, and no new work was done to the installer.