2019 pro - Slow to open


#1

Sketchup Pro 2019 seems a lot slower to open than previous versions.
When opening the program I’m sometimes waiting 10 seconds before anything even happens.

Also - Is there a way to turn off the ‘Starup Screen’ like there used to be?

Also - In Layout - the ‘Choose a template’ menu opens painfully slowly too.

But, very happy that the Layout mouse wheel zoom has been sped up.


#2

Yes. See the attached screenshot. Note that this option is disabled during trial periods.


#3

Thanks for that. Much better.