2017 Pro crashes when saving

If you want to try something with zero install, we’re working on https://my.sketchup.com, which is still in beta, and uses WebGL and a browser. There are still issues depending on dated browsers or OS’s etc… Sorry your experience wasn’t so good.

No, I’m done messing around with SketchUp 17.

You said: “help me out”? Here is my help and suggestions for Trimble:

  1. Hire themselves a well managed, competent, computer programming, team
    that can produce a useful product from the start.

  2. Hire competent customer support personnel that can quickly and
    accurately asses, identify and solve problems on the phone.

  3. As I use to tell my engineers: Solve more problems than you create.

Now, Trimble’s idea of Technical support is to tell customers to read
this, try that, while the problem persists and does not get resolved.
Barry, try asking Trimble’s programmers rather than we the customers,
who know very little about how the program was written, or the purpose
of the numerous groups of sections inside the program. As I said, it is
totally unreasonable to expect customers to solve and resolve problems
Trimble’s programmers created.

If the above is not done, I fear that SketchUp will fail. It would be a
loss to all of us if that happened.

[quote=“Barry, post:17, topic:36228”]
did you try re-running your downloaded installer as Administrator?
[/quote] @gregnier: You misunderstood @Barry.
You do not need to be an administrator or even have admin-powers to install SketchUp properly.
The correct way to install it [as outlined in the installation guidance] is to download its installer exe file…
Probably into your Downloads folder.
Then select its icon and right-click > context-menu > “Run as administrator”.
Doing things any other way - e.g. by double-clicking on its icon - will cause problems [just having admin-powers is NOT sufficient a create a good installation - especially with newer Windows versions and newer SketchUp versions…]
This ‘correct installation’ will then properly set up all permissions etc for all of the installed folders/subfolders/files.
If everything else is set up right [like your Graphics Card’s driver update and its settings], then it should work fine…

1 Like

I installed the catalyst software you suggested. It still crashed.

here’s the report info that was available when I did the bug splat:

sketchUPC6S5R44.dmp

F71T32S5.xml*

sketchUpLog-2016-12-29_03_28.log

hope that helps.

Doug E.

reply to TIG’s “run as administrator”

When I go to the default download directory (which has worked with every other download I’ve ever done) the file there is SketchUpMake-en.exe. There is no specific icon there, only a generic looking icon of a page with scribbles (like it’s denoting a document file). If I RIGHT click on the icon, the words of the .exe file I get the same window pop-up with 5 options:

remove from history
open containing folder
go to download page
copy download …
clear downloads

The only way I ever found an option to run as administrator was when I went to the search function on the start icon and found the sketchupMake-en.exe and right clicked on that. It did have the option to run as administrator which I did and it didn’t install any differently after that as when I did it by left clicking on the file in the regular download folder - still crashes.
Maybe I’m not interpreting your instructions as you wish, but I don’t know how else to do it.

Found it - as expected it’s the ATI atio6axx.dll crash. You might try looking at results like this, as SketchUp isn’t the only app that gets this. Sorry my debugging skills & time don’t allow me to do this for you right now - atio6axx - Google Search

Short reply → it still crashes.

I took your suggestion and read through the links you suggested to repair the ati06axx.dll crash problem. The one that was clearest was the Solvusoft explanation, scan, search, etc. I spent another $30 (because I’m not computer savvy enough to carry out the complicated steps suggested on my own) and downloaded the WinThruster software (despite my microtrend antivirus software saying it wasn’t a trusted site) and the free WinSweeper software packaged with the WinThruster (the WinThruster is only available that way). I ran through the installations of those two and then started SketchUP make 2017 again. It still crashes when I try to save my two line drawing. {Incidentally, the WinSweeper won’t even launch}. I think I’ve followed all the suggestions offered - I’m out $60 and no working sketchup (which I had last month, SU Make version 2016 but can’t download the old version because Trimble has taken it out of download. This all results in a rather bad experience for me. How about it, Trimble - can you offer a solution or should I just be a disappointed user that will never use any Trimble product again.

Sorry I forgot to include the bug splash specifics in my last email to you.

for what it’s worth, here they are:

report 22549

sketchUP0TFH1BR6.dmp

M084P52.sml

SketchUP log-2016-12-29-21_16_23.log

after reading through the ati06axx.dll info on Solvusoft, it appears to
me that their software looks at registry errors (whatever that means)
related to this file, but does not replace a missing file or one that
functionally is missing. Solvusoft recommends contacting the developer
of the file (i.e. AMD) for the file so I sent a request to AMD for this.
Maybe they can send me a replacement file and it will work. We can only
hope.

From what I’ve read in this forum coupled with my personal experience,
SketchUp 2017 appears to be a total disaster. As far as customer service
goes, all they do is give you the runaround without anything concrete
that works.

In your case, you have faithfully followed all, suggestions offered and
still no success. Additionally, you are out $60, with still no working
SketchUp 2017. Customer Service is a disaster too. They should re-name
themselves to “Customer Dis-service”.

You had SketchUp 2016 last month that worked. Now, you can’t download
the old working version, because Trimble took it out of the download.

I’m grateful I still have SketchUp 2015 installed and working. If not
for that, I’d be out of busyness too. You’d think Trimble would allow
you to re-install your last working version. Is this attitude
“arrogance”, or what?

Normally, I am an easy going person that will tolerate some degree of
incompetence and not complain. However, in this case, SketchUp 2017
appears to be a disaster that Trimble does not appear to acknowledge. It
sort of reminds me of the story of the king that paraded around town,
naked, while everyone was afraid to tell him the truth. Instead, they
praised him for his beautiful attire. Is this an example of “political
correctness”? Is this what’s happening at Trimble?

Details:
A proper closure of SketchUp2017 resulted in a hang-up, probably way before Mac went into sleep modus. The survey sent to Apple and pasted here was the result of a forced stop, the next morning. This happens at least twice a week….

Date/Time: 2016-12-30 10:43:16 +0100
OS Version: Mac OS X 10.12.2 (Build 16C67)
Architecture: x86_64h
Report Version: 25

Data Source: Stackshots

Command: SketchUp
Path: /Applications/SketchUp 2017/SketchUp.app/Contents/MacOS/SketchUp
Version: 17.1 (17.1.173)
Parent: launchd [1]
PID: 22953

Event: hang
Duration: 4.00s (process was unresponsive for 1577 seconds before sampling)
Steps: 40 (100ms sampling interval)

Hardware model: iMac14,1
Active cpus: 4

Fan speed: 1396 rpm

[quote=“d.eglen, post:25, topic:36228”]
open containing folder
[/quote] For completeness with the ‘Run as administrator’ part of this thread…
You are looking at your browser’s download-history and NOT the Downloads folder itself.
Choose the browser’s option [above] and the download folder should open - then you will see the installer file’s exe icon and proceed from there, using its right-click menu item as previously outlined…

Tig:

I did as you said and did find the download folder, not the download
history (which on my Firefox browser is a blue arrow at the top right of
the web page present when downloading). It did indeed show the SKetchUp
icon (along with the icon of my Trend Micro software antivirus). I
right clicked and ran as administrator. It only gave me a choice of
repair or uninstall. I chose repair. Unfortunately, the results were the
same. Crash upon saving.

Here’s the bug splat report # 22764

SketchUp FLPT5TL5.dmp

ES7L4JU7.xml

SketchUPLog-2016-12-30-11_13_54.log

Also I did receive a reply from AMD techinical support which had
detailed suggestions, which I will try (if I’m capable of understanding
them) later today and report.

thanks for trying to help. I realize this is frustrating for all.

@d.eglen
At least you now know SketchUp is installed properly…

I followed the suggestions by AMD tech support which was first to run the command regsvr ati06ax.dll, then try sketchup. that didn’t work. it still crashed on saving. Next to use DDU (display drive uninstaller) . I went to the link he provided. That took me back to DriveUpdate software, which I had just bought yesterday. I did the chat and was transferred to their technical support. He took control of my computer and watched while I did the sketchup routine and he saw it crash again. He checked the device registry and said that the Radeon HD 4200 was installed properly and was functioning properly. He said the problem is in the program. I said that isn’t what the SketchUp people tell me. He insists that it is and I have copied his comments to prove what was done and said. So now, I’m in the middle and have no solution. Isn’t it possible to ask Trimble for a link so I can get 2016 or even 2015 back?
I think I’ve been through enough misery for 2017.

Do not uninstall your SketchUp 2015 and/or SketchUp 2016.

Trimble must have a computer system that works flawlessly
using SketchUp 2017. I would be interested to know exactly what their
computer configuration is.
If I were to exactly match and duplicate their computer system,could I
make SketchUp 2017 work properly and save work without crashing? That would be an expensive and interesting proof of software integrity and also get a new computer system at the same time.

[quote=“gregnier, post:37, topic:36228”]
I would be interested to know exact what their computer configuration is,
[/quote]I am not from Trimble. I have two old computers that both run SketchUp 2017 without any problems. The other is a desktop I had built by a local shop, with a 4-core i7 processor, 8 gigs of memory and a discontinued Nvidia Quadro FX 1800 video card with 768 MB of VRAM, running Windows 7 Pro wih an external FullHD monitor. The other is an old Asus utrabook with a 2-core i7, 6 gigs of memory and a 1 GB Nvidia GeForce 620M display running Windows Home 8.1 on a ridiculously small FullHD monitor. I haven’t installed SketchUp 2017 at work yet - the systems there are a bit different but they run 2016 OK.

For a while, AMD driver updates bundled in a few extra apps, one called Play.tv caused SU to crash. Check if you have it through Control Panel > Programs > Uninstall a program. Uninstall it if it’s there.

Some antivirus programs throw an overprotective, hissy fit with newly installed programs. This may have to do with SU’s registry changes - which do evil things like allowing the program user to save toolbar locations. Which get back to the Run as administrator thing, a security protocol MS introduced with Vista to ensure a responsible human allows a few registry changes. To check antivirus interference, open SU to get the welcome screen is enough. open antivirus program and try to find some dialog showing running processes. With Webroot, I can access this by r-clicking on the status bar icon. Check to see if SU apps are being allowed instead of being monitored or blocked.

Rule out (or in) some other background program interfence by open SU in a clean boot.state. It’s done with a utility included with Windows and relatively easy to set up. I recently helped someone find a program that interfered with their very nice NVIDIA card’s driver which caused SU to crash with this troubleshooting method.

BTW, I never had any issues running SU17 on my custom machine which I assembled from components I bought at some very discounted sale prices from local Fry’s Electronics store. Though I do have an NVIDIA graphics card, I’ve been very impressed at how well SU17 has been running on machines with AMD and Intel chipsets given the elevated system requirements. Pre-SU17 (which now requires hardware acceleration), many AMD and integrated Intel graphics machines had to be set to use CPU rendering (that option isn’t available with SU17.)

I’m running SketchUp 2017 Pro on three different PCs and an old MacBook Pro. It runs flawlessly on all of them.