2017 not launching

#!! NEW UPDATE 2/22/17 !!
Howdy everybody! As you may have noticed, SketchUp Pro 2017 M2 is here! 2017 does have some additional System Requirements as compared to earlier versions of SketchUp. We’ve had some reports of users installing 2017, double clicking the EXE, and nothing happens. We modified the M2 release so that our bug reporting software (bugsplat) will start up and should create a crash report now. Please make sure and install the latest version of SketchUp to get this crash report.

There are a few issues that could cause this behavior:

#1. Video card driver out of date. Please try the steps found here to update your video card driver

1A: If you have a built in video card (like an Intel 4600), you may need to contact your computer manufacturer to get the latest driver (ie Dell, HP, etc).

1B: If you are having trouble getting an updated driver for your Intel video card, please try the steps found in this forum page from Yogesh.

#2. If you have multiple video cards, you may need to set which one SketchUp uses, please follow the steps found here

#3. SketchUp requires several pre-reqs to install, please run Windows update and also install .Net and C++ Runtime library

#4. If you got this crash report after submitting the bugsplat, it is likely that your video card does not meet our System Requirements and will need to be upgraded to use SketchUp 2017.

** Previous UPDATE **
If SketchUp then launches but crashes after launch, we’ve seen some issues where the Microsoft Visual Studio C++ 2015 Redistributable that SketchUp 2017 requires to run needs to be reloaded to let SketchUp run. Please try the following:

  1. Quit SketchUp (and LayOut)
  2. Go to Add/Remove Programs and uninstall the Microsoft Visual Studio C++ 2015 Redistributable (there may be a 32-bit and 64-bit version)
  3. Re-run the SketchUp 2017 installer as a Repair (you can download it here if you need it: http://www.sketchup.com/download/all)
  4. Start SketchUp

This should get that library reset so that SketchUp can get running for you.



I have been facing an issue with SketchUp as well, but slightly different than yours, in terms of operating systems. I moved the SketchUp folder to Applications, in mac, and after a few times of opening it, an error message box popped saying,“SketchUp cannot open because of a problem.”

Here is the diagnosis that showed up if anyone replying to this is a developer. Is there a way to fix this without having to reinstall the app, and then having to do this process over and over every few days?

Process: SketchUp [22280]
Path: /Applications/SketchUp 2017/SketchUp.app/Contents/MacOS/SketchUp
Identifier: com.sketchup.SketchUp.2017
Version: ???
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: SketchUp [22280]
User ID: 501

Date/Time: 2016-11-16 12:34:54.331 -0500
OS Version: Mac OS X 10.11.6 (15G1108)
Report Version: 11
Anonymous UUID: 1B315043-54A0-4240-80B4-1E33B5DE8E41

Sleep/Wake UUID: 6DA017B8-292A-459F-8806-4CB20AC669D1

Time Awake Since Boot: 62000 seconds
Time Since Wake: 430 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @rpath/libCommonGeoformats.dylib
Referenced from: /Applications/SketchUp 2017/SketchUp.app/Contents/MacOS/SketchUp
Reason: image not found

Binary Images:
0x7fff6f3a9000 - 0x7fff6f3e0a47 dyld (360.22) /usr/lib/dyld
0x7fff8c917000 - 0x7fff8ca3bfff libsqlite3.dylib (216.4) <280D67B8-F93D-3587-A146-19F36C817548> /usr/lib/libsqlite3.dylib
0x7fff97263000 - 0x7fff972c1fff com.apple.SystemConfiguration (1.14 - 1.14) /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration

Model: MacBookAir6,1, BootROM MBA61.0099.B22, 2 processors, Intel Core i5, 1.3 GHz, 4 GB, SMC 2.12f143
Graphics: Intel HD Graphics 5000, Intel HD Graphics 5000, Built-In
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3230554638454455302D474E2D4620
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1600 MHz, 0x02FE, 0x45424A3230554638454455302D474E2D4620
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x117), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.4.6f1 17910, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SD0128F, 121.33 GB
USB Device: USB 3.0 Bus
USB Device: BRCM20702 Hub
USB Device: Bluetooth USB Host Controller
Thunderbolt Bus: MacBook Air, Apple Inc., 23.6

For mac users; Has anyone else faced this problem?

1 Like

That’s trying to open “/Applications/SketchUp 2017/SketchUp.app/Contents/Frameworks/libCommonGeoformats.dylib”. Weird that it failed to load… how big is the file if you open Terminal and do

ls -al “/Applications/SketchUp 2017/SketchUp.app/Contents/Frameworks/libCommonGeoformats.dylib”

It should be 3,979,024 bytes. So you’re saying you have to recopy it in again? Is someone mucking with your machine?

1 Like

I’m not a Trimble developer, just a somewhat avid Mac user, but I’ll see if I can help.

For starters, I’m confused by your statement “I moved the SketchUp folder to Applications”. How did you install SketchUp in the first place? If you open the .dmg, it will show a window in which you drag the SketchUp icon over to the Applications icon and the package scripts take care of the details. If you did something else, it is hard to be certain how things are actually installed on your Mac.

The error you posted says that for some reason the system’s library loader can’t find the libCommonGeoformats.dylib file. This file should be located in

/Applications/SketchUp 2017/SketchUp.app/Contents/Frameworks

That @rpath in the Library not loaded message says the loader was looking for it in a place relative to where the SketchUp executable was loaded, which should have led to the folder given above. If the library is not there, you have somehow garbled the installation and by far your easiest course may be to start anew. It doesn’t take long to install SketchUp, and all of your customizations are kept in your user folder so there is no risk of losing anything.

1 Like

The DMG properly installed SketchUp, so a disc icon appears on your desktop. Then, when I double-clicked the disc icon, the SketchUp folder appeared, with an arrow coming from it to the ‘Applications’ folder. I dragged it in, and it is in applications. I opened SketchUp a few times, and when I had to force quit the app because I did something simple, like rotate a component, I couldn’t open the application again, and that window appeared. Google Earth had the same issue, and I wonder if it’s a flaw with Application Support, or some directory in Mac OS.

How did you force quit? If you cmd-option-esc, and you had the spin cursor, you should have been presented a spin dump. It’s highly unlikely, i.e. - I’ve never seen it, that this would be a flaw in a directory. What’s more likely is that something didn’t completely die and unload, preventing the next load. My question would be: when this happens next time (hangs), just cmd-opt-shift-q and log out (which will kill your user-loaded processes) and log back in and see if you can restart. You certainly shouldn’t have to re-drag anything.

Precisely so. After that, the Message Box came up and said “You forced “SketchUp” to quit”. There were two options, ‘cancel’, and ‘Send to Apple’. Since it wasn’t from a mac developer, I hit ‘cancel’. I think I would know if someone was “Mucking” my machine, but this doesn’t happen when I keep it on my Desktop. Before this happened, I ejected the “SketchUp” disk. Then, I had to re-download the DMG, then it happened again, when I moved it to the “Applications” folder. Is there a missing image in the program, because one of the diagnosis were “Image Not Found”.

“Image” in that message refers to a binary code file, not a file containing a picture. Coder jargon!

If you eject the disk after installing, the DMG will still be in your downloads folder, so no need to re-download. @slbaumgartner is right, and since you’re still on El Capitan, it’s not an app translocation (google that for fun reading) issue because that’s Sierra only, and we’re signed. Anti-virus installed?

a 30 day trial period with unlimited functionality of a commercial business software is more than generous.

not really, professional 3D modelers typically start in this price region… not everything is freeware/open source, especially in the CAx area.

surely not, even the low-end intel HD GPU integrated in the CPU does work… with a recent driver of course.

for a personal/non-commercial usage you may want get generously (again) the free but functionally limited SketchUp Make version

pretty inappropriate ranting * imho *


Sketchup 2017 restrictions prevent it from running when in a Windows Remote Desktop session. I often need to access my work computer from home, and since upgrading to 2017 I am no longer able to open the Sketchup application remotely. That being said, I have discovered that if I leave the Sketchup application running, it works just fine remotely. This is not always possible, so Is there a work around to allow Sketchup to startup when using a Windows Remote Desktop session?


I updated the drivers for the integrated graphic card and for my Nvidia Geforce GTX 960M, 16 GB. Afterwards SU 2017 won´t launch. I have windows 10, 64-bit. When I press “Start using sketchup” it shuts down and bugsplat pops up. I ran SU checkup that told me - Error: Your “Intel® HD Graphics 530” graphics card has 1 MB of graphics card memory. SketchUp requires a graphics card that has 256 MB or more of memory.
Warning: SketchUp has detected you are using a “Intel® HD Graphics 530” graphics card when your system is capable of using an AMD or NVIDIA graphics card. SketchUp will likely perform better if you change your system to use the AMD or NVIDIA card.

I´ve tried pretty much everything I know (sadly, in my case not that much). I’ve performed suggested actions described in the second instruction above. Did not help. I’ve uninstalled and reinstalled SU. I’ve updated pretty much everything. Don’t know what to do. I would be very grateful for help solving this issue.

Best Regards

@cromland as you have a laptop, you need to adjust setting in NVIDIA control panel, 3D settings, under the menu to adjust stuff per program, for your laptop to use your NVIDIA card instead of using the default use of the Intel chipset.

Tried that. I’ve set it to use the Nvidia and not the Intel chip, doesn’t work. Checkup repeats that it tries to use the Intel chip, even if I right-click on the SU-icon and click launch with Nvidia.

Did you change the setting through the NVIDIA control panel itself?

And when you reinstalled SU17, did you r-click on the installer and select Run as administrator?

I’ve changed the setting in the Nvidia control panel and installed SU17 as administrator.

Did you submit the bugsplats along with contact info?

Note this holiday week may greatly delay a SU staffer response.

Yes I have. Now, after a couple of hours sleep I will try to roll back my drive routines for the graphic cards.